Some users unable to login to Dashboard
Incident Report for Fauna
Postmortem

On June 18th at 19:55 UTC, a change to our Dashboard was released which prevented some users from authenticating to the Fauna Dashboard. This was resolved when we rolled back the change on June 21st at 10:55 UTC. The impact of this problem went unnoticed for multiple days due to the fact that it impacted a subset of users and was not widespread. Specifically, it impacted Non-Admins in Team accounts who logged in two or more times during the duration of the incident.

This defect resulted from populating account data relating to a migration we have underway. The migration worked as expected for Admin and Owner accounts, and our testing of member accounts did not include a logout and re-login which would have caught this defect prior to reaching production.

Changes underway to ensure defects of this nature do not reoccur:

  • Monitoring for changes in Authentication Error rates
  • Automated testing for Team Member accounts to include logout and re-authenticate.

The root cause of the problematic code path has been addressed in production and the system is working as expected today. We prioritize the availability, security, performance, and correctness of our service above everything else and apologize for any inconvenience that this event may have caused you. If you have further questions/comments about the event or require assistance with any remaining issues related to it, please reach out to support@fauna.com.

Posted Jun 28, 2021 - 14:27 PDT

Resolved
We have resolved the issue that was not allowing some users to login to the Dashboard. The service is now operating normally.
Posted Jun 21, 2021 - 04:10 PDT
Investigating
We are investigating an issue that is not allowing some users to login to the Dashboard.
Posted Jun 21, 2021 - 03:22 PDT
This incident affected: Classic Region Group (FQL API).